Brian's Blog
Happy Coding

解决Node.js升级后Hexo报错

目录

  1. 安装模块n (该模块可以管理Node.js的版本)
  2. 升级Node.js

以前对Node.js不是很了解,最近认真的学习了一下Node.js,在学习过程中发现自己Node.js版本过低,于是升级了Node.js,在此说一下Node.js的升级吧!

安装模块n (该模块可以管理Node.js的版本)

1
npm install -g n

升级Node.js

1
n lts

LTS版本为长期支持版本,稳定性比最新版本好。

安装好了Node.js,发现在Hexo相关命令运行时报错,然后各种搜索答案,找到了一条命令,具体是更新还是重新安装,我也不知道,查了文档,没能读懂其意思。希望各位大大们解答…

1
sudo npm install --unsafe-perm --verbose -g hexo

到此问题解决啦!嘻嘻…